Channel Maintenance
Incident Report for TVPlayer
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 06, 2019 - 12:44 GMT
Identified
The channels Eurosport1, Eurosport2, Investigation Discovery and Animal Planet will be unavailable for a short time while we perform maintenance on them.
Posted 6 months ago. Mar 06, 2019 - 12:26 GMT
This incident affected: Live Streams.