TVPlayer.com Connectivity Issues
Incident Report for TVPlayer
Resolved
The connectivity issues are now resolved.
Posted 4 months ago. May 10, 2019 - 22:03 BST
Investigating
TVPlayer.com is experiencing connectivity issues.
Posted 4 months ago. May 10, 2019 - 21:58 BST