TVPlayer.com (website only) - Log In issues
Incident Report for TVPlayer
Resolved
The connectivity issues are now resolved.
Posted 4 months ago. May 04, 2019 - 17:49 BST
Update
We are continuing to investigate this issue.
Posted 4 months ago. May 04, 2019 - 16:51 BST
Update
We are continuing to investigate this issue.
Posted 4 months ago. May 04, 2019 - 16:48 BST
Investigating
TVPlayer.com log in issues.

The website is currently experiencing an issue where users are unable to log in.

Please do not reset your password why we work to resolve this issue.

You can still access the service through our apps.

Apologies for the inconvenience.
Posted 4 months ago. May 04, 2019 - 15:59 BST
This incident affected: Live Streams and Website.