TVPlayer.com Connectivity Issues
Incident Report for TVPlayer
Resolved
The connectivity issues are now resolved.
Posted 5 months ago. Apr 06, 2019 - 17:24 BST
Investigating
TVPlayer.com is experiencing connectivity issues.
Posted 5 months ago. Apr 06, 2019 - 17:23 BST