TVPlayer.com Connectivity Issues
Incident Report for TVPlayer
Resolved
The connectivity issues are now resolved.
Posted 4 months ago. May 07, 2019 - 20:10 BST
Investigating
TVPlayer.com is experiencing connectivity issues.
Posted 4 months ago. May 07, 2019 - 20:09 BST